VLAN Voice

Voice-VLANs trennen Sprach- und Datenverkehr.

Möglicher Aufbau: IP-Phone in Voice VLAN 400. An diesem IP-Phone ist direkt ein Notebook angeschlossen.

------------------------------
| Switch                     |
------------------------------
     |
--------------   -------------
| IP-Phone   |   | Laptop    |
| Voice VLAN |---| Data VLAN |
| 400        |   | 300       |
--------------   -------------

Voice VLAN Definition

Ein VLAN, das auf einem Cisco-Switch konfiguriert werden kann, damit Sprach- und normale Daten gleichzeitig über ein IP-Telefon übertragen werden können.

Es gibt verschiedene Konfigurationsmöglichkeiten

Bisher heißt es, dass ein Switchinterface, das mit Modus 'access' konfiguriert wurde, nur zu einem VLAN gehören kann.

Nun gibt es eine Ausnahme. Cisco deht diese Regel aus. Ein Daten-VLAN une ein Voice-VLAN können über einen(!) Port übermitteln.

Single-VLAN-Access-Port

IEE 802.1p

Ein Markierungsfeld im dritten byte des 4-Byte-802.1Q-Headers als 3-Bit-Feld. Es liefert acht mögliche Werte zur Markierung.

Mit dieser Markierung kann - in diesem Beispiel - das VLAN 400 mit den Voice-Nachrichten eine höhere Priorisierung gegenüber dem Daten-VLAN 300 erhalten. Die Sprachdaten werden schneller übermittelt. Ohne diesen Modus wäre die Sprachqualität unzureichend.

Class of Service (CoS)

Das ist eine Layer 2 Qualitiy of SErvide-(QoS)Markierung, die bei einem Trunk zum Einsatz lpmmen kann. Werte liegen zwischen 0 und 7. Cisco-IP-Telefone setzen automatish den CoS für 'voice frames' auf 5.

Multi-VLAN-Access-Port

Link Layer Discovery Protcol - Media Endpoint Discovers (LLDP-MED)

Eine Erweiterung des LLDP, um eine Interoperabilität von VoIP- Endgeräten mit anderen Geräte im Netzwerk (z. B. PC) zu unterstützen.

Trunk-Port


Beispiele

Kommandobeispiele, ein Voice-VLAN einzurichten. Kommandos werden über putty an einem physischen Switch eingegeben.

Single-VLAN-Acces-Port konfigurieren

die Kommandos werden gezeigt. Das VLAN 300 ist noch nicht erstellt. Darum geht es an dieser Stelle nicht darum, das VLAN zu konfigureren.

Switch>ena
Password:
sw01#conf t
Enter configuration commands. one per line. 
   End with CNTL/z.
sw01(config)#interface g 1/0/1
sw(config-if)#switchport mode access
sw(config-if)#switchport access vlan 300
[VLAN erstellt, Port zum VLAN hinzugefügt]
sw(config-if)#switchport voice vlan ? [zeigt die Hilfe an]
  <1-4094>  vlan for voice traffic
  dot1p     Priority tagged on PVID
  none      Don't tell telephone about voice vlan
  untagged  Untagges on PVID
[Es ist eine Art Trunkport, es wird eine Art Trunk-Frame 
eingesetzt 8021q, jedoch nicht direkt. Es ist eine spezifische 
Markierung, wenn Sprachdaten übermittelt werden, diese zu priorisieren.]
sw(config-if)#switchport voice vlan

sw01(config-if)#switchport voice vlan dot1p
sw01(config-if)#exit
sw01(config)#

Der Single-VLAN-Accessport ist konfiguriert.

Multi-VLAN-Access-Port konfigurieren

sw01(config)#interface g 1/0/2
sw01(config-if)#switchport mode access
sw01(config-if)#switchport access vlan 300
sw01(config-if)#switport voice vlan 400
%Voice VLAN does not exist. Creating vlan 400
sw01(config-if)#exit

Der Multi-VLAN-Accessport ist erstellt.

Trunk-Port konfigurieren

sw01(config)#interface g 1/0/3
sw01(config-if)#switchport trunk ? [zeigt die Hilfe an]
  allowed        Set allowed VLAN characteristics when
                 interface ist in trunking
  encapsulation  Set trunnking encapsulation when 
                 interface is in trunking mode       
  native         Set trunking native chracteristics when
                 interface is in trunking mode
  pruning        Set pruning VLAN characteristics when
                 interface is in trunking mode

sw01(config-if)#switchport trunk encapsualtion dot1q
[IEE802.1q ist eingerichtet]

sw01(config-if)#switchport mode trunk
sw01(config-if)#switchport voice vlan 400
[Konfiguration Trunkport ist abgeschlossen]

[Zusätzlich soll VLAN 300 über diesen Switchport
übertragen werden]

[Zusätzlich VLAN 300 übermitten - Vorsicht!]
sw01(config-if)#switchport trunk allowed 300,400
[Alle erlaubten VLANS mit Komma auflisten,
sonst wird vorherige Konfiguration überschrieben.]
sw01(config-if)#end
sw01#

Der Trunk-Port ist konfiguriert.

Konfiguration Interface 2 anschauen

sw01#show interfaces gig 1/0/2 switchport
Name: Gi1/0/2
Switchport: Enabled
Administrative Mode: statistic access
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: off
Access Mode VLAN: 300 (VLAN300)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: 400 (VLAN400)
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAn tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mapping: none
Operational private-vlan: none
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs allowed: All

Protected: false
Unknown unicast blockes: disabled
Unknown multicast blockes: disabled
Appliance trust: none
sw01#

Konfiguration Interface 3 anschauen

sw01#show interfaces gig 1/0/3 switchport
Name: Gi1/0/3
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: on
Access Mode VLAN: 1 (defautl)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: 400 (VLAN400)
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAn tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: 300,400
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs allowed: All

Protected: false
Unknown unicast blockes: disabled
Unknown multicast blockes: disabled
Appliance trust: none
sw01#

Quelle: Tom Wechsler

Akzeptieren

Diese Website verwendet Cookies. Durch die Nutzung dieser Webseite erklären Sie sich damit einverstanden, dass Cookies gesetzt werden. Mehr erfahren